Автоматизация бизнеса

Установка, настройка, внедрение и сопровождение любых конфигураций на платформе 1С:Предприятие.

Тел: 8(985)141-74-63 Дмитрий.   
ICQ:     552-608-881
e-mail: info@programmist1c.ru

Оплата после выполнения работы.

  •   Удаленный админ
  •   Карта сайта
  •   Контакты


  • Поиск
     

    v8: Сохранение настроек построителя отчета в стандартных настройках

    1С в конструкторе использует слишком сложный метод сохранения настроек построителя. Существует более простой способ.
    Автор статьи: Гений 1С | Редакторы:
    Последняя редакция №2 от 06.06.07


    Ключевые слова: построитель,настройки,сохранение настроек


    Добавляем в реквизиты отчета (именно отчета, а не формы, иначе не будет сохраняться) реквизит НастройкиПостроителя с типом "Строка неограниченной длины".
    Добавляем его в список "Сохраняемые значения".

    Далее, используем такой код:

    Процедура ПередСохранениемЗначений(Отказ)
        ...
        НастройкиПостроителя=ЗначениеВСтрокуВнутр(Построитель.ПолучитьНастройки());
        ...
    КонецПроцедуры
    
    Процедура ПриОткрытии()
        ...
        Построитель.Текст="";
        Построитель.ЗаполнитьНастройки();
        ...
        Если СокрЛП(НастройкиПостроителя)<>"" Тогда
            Попытка
                Построитель.УстановитьНастройки(ЗначениеИзСтрокиВнутр(НастройкиПостроителя));
            Исключение
            КонецПопытки;
        КонецЕсли;
        ...
    КонецПроцедуры
    21.02.18 | 10:31


    30.11.16 | 20:25


    28.11.16 | 09:22


    26.11.16 | 08:19


    22.11.16 | 20:17


    19.11.16 | 10:14


    18.11.16 | 20:09




    Внедрение 1С Автоматизация 1С Доработка 1С Сопровождение 1С Обслуживание 1С Программирование 1С 8 Hастройка 1С Карта сайта Контакты