Автоматизация бизнеса

Установка, настройка, внедрение и сопровождение любых конфигураций на платформе 1С:Предприятие.

Тел: 8(985)141-74-63 Дмитрий.   
ICQ:     552-608-881
e-mail: info@programmist1c.ru

Оплата после выполнения работы.

  •   Удаленный админ
  •   Карта сайта
  •   Контакты


  • Поиск
     

    v8: Как выбрать значения регистра сведений через com - соединение?

    Не могу организовать отбор регистров сведений через com - соединение. Помогите примером.
    Автор статьи: minasyan | Редакторы: unior
    Последняя редакция №2 от 02.10.07 | История


    V8 = Новый COMОбъект("V8.ComConnector");
                  Соединение=v8.Connect("Srvr="""+"1c.1c.local"+""";Ref="""+"LZK_20070731"+""";Usr="""+"Обмен"+""";Pwd="""+""+""";");

                     Выборка = Соединение.Справочники.контрагенты.Выбрать();
           i=0;
           Контр=Справочники.Организации;
           Пока Выборка.Следующий() Цикл
                           ЮрЛицо=Выборка.ОсновноеЮрФизЛицо;
                   Отбор = Новый Структура("Объект", ЮрЛицо);
                   СрезПоследних   = Соединение.РегистрСведений.КонтактнаяИнформация.СрезПоследних(ТекущаяДата(),Отбор);
                   Если СрезПоследних.Количество() = 1 Тогда
                   НовыйКонтрагент.АдресФактический=СрезПоследних.Представление;
                   КонецЕсли;
                   КонецЦикла;
           КонецЦикла;
    ОШИБКА:Ошибка при вызове метода контекста (СрезПоследних): Произошла исключительная ситуация: Несоответствие типов (параметр номер "2")
                       СрезПоследних   = Соединение.РегистрыСведений.КонтактнаяИнформация.СрезПоследних(ТекущаяДата(), отбор);
    по причине:
    Произошла исключительная ситуация: Несоответствие типов (параметр номер "2")
    21.02.18 | 10:31


    30.11.16 | 20:25


    28.11.16 | 09:22


    26.11.16 | 08:19


    22.11.16 | 20:17


    19.11.16 | 10:14


    18.11.16 | 20:09




    Внедрение 1С Автоматизация 1С Доработка 1С Сопровождение 1С Обслуживание 1С Программирование 1С 8 Hастройка 1С Карта сайта Контакты